Установка и авторизация NormaCS

1 Системные требования

Прежде чем начать установку NormaCS убедитесь, что характеристики аппаратных и программных средств, на которые будет производиться установка, соответствуют системным требованиям NormaCS.

1.1 Процессор

Современный многоядерный процессор архитектуры Intel или AMD.

1.2 Оперативная память

►NormaCS Desktop:

1 Гб (рекомендуется 4 Гб и более для 64-битных ОС)

►NormaCS Server:

4 Гб (рекомендуется 8 Гб и более для 64-битных ОС, в зависимости от количества сетевых лицензий)

►Сетевой клиент NormaCS Server:

1 Гб (рекомендуется 4 Гб и более для 64-битных ОС)

1.3 Свободное дисковое пространство

  • Для установки и работы программы – 2 Гб.
  • До 300 Гб для данных (полные базы)

1.4 Дополнительные устройства

Устройство для чтения DVD-ROM.

Мышь или другое устройство указания.

1.5 Операционная система

►NormaCS Desktop:

  • Microsoft Windows 7 (32/64-bit)
  • Microsoft Windows Vista (32/64-bit)
  • Microsoft Windows XP (32/64-bit)

►NormaCS Server:

Рекомендуется:

· Microsoft Windows 2012 (32/64-bit) Server

· Microsoft Windows 2008 (32/64-bit) Server

· Microsoft Windows 2003 (32/64-bit) Server

Не рекомендуется, но может быть использовано:

  • Microsoft Windows 7 (32/64-bit)
  • Microsoft Windows XP Professional (32/64-bit)

►Сетевой клиент NormaCS:

  • Microsoft Windows 7 (32/64-bit) с поддержкой протокола TCP/IP
  • Microsoft Windows Vista (32/64-bit) с поддержкой протокола TCP/IP
  • Microsoft Windows XP (32/64-bit) с поддержкой протокола TCP/IP

Указанные операционные системы следует использовать с установленными на них новейшими обновлениями фирмы Microsoft.

1.6 Установленные программы

На компьютере с установленной NormaCS Desktop или сетевым клиентом NormaCS Server должен быть установлен браузер Microsoft Internet Explorer версии не ниже 7.0.

2 Состав коммерческой версии

2.1 Комплектация

Коммерческая версия NormaCS поставляется в пластиковой коробке и содержит:

  • Сменный носитель с программным продуктом и архивом документов (конкретный состав поставки определяется дилером)
  • Краткое описание для быстрого ознакомления с программой
  • Ключ аппаратной защиты (не обязательно)

Программа защищена файлом лицензии, а также файлом разделов, содержащим информацию о приобретенных документах. Эти файлы поставляются по завершении основной установки мастером регистрации и мастером установки документов.

После установки и авторизации программы вы можете проверить тип установленной версии коммерческая, учебная, демо-версия с указанием времени работы программы и т.д.) в разделе О программе.

2.2 Установочные диски

Первый диск содержит следующие папки и файлы.

  • Корневая папка

o    Метка диска

o    Описание поставки

o    Контрольные суммы файлов на диске

o    Шаблон для указания информации о дилере

o    Файлы меню автозапуска

  • Папка addonBase – архивы документов для дополнительных баз данных
  • Папка addons – надстройки для работы с дополнительными форматами документов
  • Папка autorun – меню автозапуска
  • Папка documentation

o    Руководство по установке и авторизации (этот документ)

o    Руководство администратора NormaCS Server

o    Руководство пользователя

  • Папка documents – документы NormaCS
  • Папка npu – обновления для основной и/или дополнительных баз данных
  • Папка sentinel_drivers – установка драйверов для электронных ключей защиты типа SafeNet Sentinel
  • Папка wibu_drivers – установка драйверов для электронных ключей защиты типа WIBU-BOX/RU+
  • Папка setup – установка NormaCS

Остальные диски (для варианта поставки на DVD-дисках):

  • Корневая папка

o    Метка диска

o    Описание поставки

o    Контрольные суммы файлов на диске

  • Папка documents – документы NormaCS.

3 Установка NormaCS

Для установки NormaCS пользователь должен иметь права администратора.

Чтобы запустить установку NormaCS, следует выбрать соответствующий пункт меню автозапуска или вызвать файл setup.exe, расположенный в папке setup установочного диска.

Обратите внимание! Не подключайте электронный ключ защиты к компьютеру до завершения установки драйвера аппаратной защиты для данного ключа!

После завешения установки следует выполнить авторизацию NormaCS и установку документов.

3.1 Начало установки

В окне приветствия нажмите кнопку Далее.

3.2 Ввод регистрационных данных

►Для регистрации коммерческой версии укажите свое имя, название организации и серийный номер продукта.

3.3 Выбор папки для программных файлов

►Укажите папку, в которую будут установлены программные файлы.

3.4 Выбор папки для данных

►Укажите папку, в которую будут установлены файлы данных.

3.5 Выбор дополнительных баз данных

►Укажите дополнительные базы, которые следует установить.

Пожалуйста, обратите внимание, что коммерческие базы не показываются этом в списке, они будут выбраны и установлены автоматически на основании данных о подписке в контрольном файле, получаемом при авторизации NormaCS.

3.6 Указание параметров сервера

Этот шаг выполняется только при установке NormaCS Server.

►Укажите номер TCP-порта прослушивания и пароль администрирования сервера.

После установки и авторизации эти данные могут быть изменены из административной консоли сервера. Более подробная информация приведена в Руководстве администратора NormaCS Server.

3.7 Указание IP-адресов клиентов

Этот шаг выполняется только при установке NormaCS Server.

►Укажите IP-адреса компьютеров, с которых разрешен доступ к серверу.

После установки и авторизации эти данные могут быть изменены из административной консоли сервера. Более подробная информация приведена в Руководстве администратора NormaCS Server.

3.8 Настройка NTLM

Этот шаг выполняется только при установке NormaCS Server.

►Укажите, следует ли использовать NTLM-аутентификацию, и установите ее параметры: номер TCP-порта прослушивания запросов на NTLM-аутентификацию и IP-адреса не подлежащих NTLM-аутентификации компьютеров. После установки и авторизации эти данные могут быть изменены из административной консоли сервера. Более подробная информация приведена в Руководстве администратора NormaCS Server.

При выборе NTLM-аутентификации в конце установки будет запущен мастер настройки доступа к NormaCS серверу.

3.9 Настройка брандмауэра Windows

Этот шаг выполняется при установке NormaCS Server на платформе с брандмауэром Windows (Windows XP SP2+, Windows 2003 SP1+).

►Укажите, должны ли быть автоматически открыты брандмауэром Windows указанные вами ранее порты NormaCS сервера.
Укажите также, для каких компьютеров должен быть разрешен доступ к указанным портам.

ВНИМАНИЕ! При наличии в системе брандмауэра (в частности, брандмауэра Windows) порты сервера обязательно должны быть открыты для внешнего доступа с целью обеспечения нормальной работы клиентов сервера.

3.10 Выбор папки меню

►Укажите папку, в которую следует поместить ярлыки для запуска NormaCS.

После установки NormaCS Desktop указанное меню включает ярлык для запуска однопользовательского приложения. После установки NormaCS Server меню включает ярлыки для запуска и остановки службы NormaCS Server, а также ярлыки для администрирования сервера через браузер.

3.11 Установка драйвера аппаратной защиты

Не подключайте электронный ключ защиты к компьютеру до завершения установки драйвера!

►Укажите тип драйвера аппаратной защиты, необходимого для электронного ключа из комплекта поставки:

SafeNet Sentinel

или WIBU-BOX/RU+

3.12 Перед выполнением

►Убедитесь в правильности указанных настроек.

3.13 Выполнение

►Дождитесь завершения процесса установки основных компонент.

3.14 Установка драйвера аппаратной защиты

Этот шаг выполняется в том случае, если установка драйвера аппаратной защиты была затребована ранее.

► На этом шаге запускается программа установки драйверов аппаратной защиты.По завершению установки необходимо вставить ключ защиты и, в случае, если ключ не будет автоматически распознан системой, запустить Мастер установки оборудования (Пуск > Панель управления > Установка оборудования) для того, чтобы операционная система произвела поиск и установку указанного устройства аппаратной защиты.

3.15 Установка службы сервера

Этот шаг выполняется только при установке NormaCS Server.

► Выполняется автоматическая установка службы сервера.

3.16 Завершение установки

►Нажмите кнопку Готово, чтобы завершить установку.

Установите опцию “Запустить мастер регистрации” для ввода и отсылки регистрационных данных по окончании установки. Порядок работы с Мастером регистрации представлен в разделе Авторизация NormaCS.

Мастер регистрации может быть запущен позднее выбором сответствующего пункта меню NormaCS.

При установке NormaCS Desktop указанный экран включает также опцию запуска Мастера интеграции NormaCS.

Порядок работы с Мастером интеграции представлен в разделе Мастер интеграции NormaCS.

Мастер интеграции может быть запущен и позднее посредством выбора пункта меню NormaCS ® Мастер интеграции - в Старт-меню или Правка ® Настройки в меню приложения NormaCS.

После завешения установки следует выполнить авторизацию NormaCS и установку документов.

4 Авторизация NormaCS

Авторизация выполняется при помощи Мастера регистрации.

Версия программы регистрируется только на текущий компьютер!

При необходимости установить на разные компьютеры несколько ознакомительных версий NormaCS процедуру регистрации программы следует повторить для каждого компьютера. Для каждой установки будет прислан свой файл лицензии.

По завершении процесса авторизации необходимо будет запустить Мастер документов для установки архива документов.

4.1 Предварительные действия

При наличии ключа аппаратной защиты, необходимо проделать следующие действия перед запуском Мастера Регистрации

Если драйвер аппаратной защиты еще не установлен, установите на компьютере драйвер аппаратной защиты для электоронного ключа из комплекта поставки:

  • если в комплекте поставки ключ SafeNet Sentinel, то выполните "Sentinel System Driver Installer 7.5.0.exe" из папки sentinel_drivers дистрибутива.

o   если в комплекте поставки ключ WIBU-BOX/RU+, то выполните Setup.exe из папки wibu_drivers дистрибутива. Обратите внимание, установка драйвера идет в абсолютно “молчаливом” режиме, никаких окон и сообщений не выдается.Установка занимает 20-30 секунд.

►Вставьте ключ аппаратной защиты в USB порт вашего компьютера. Обратите внимание, ключ необходимо вставлять непосредственно в локальный порт USB 2.0 компьютера (можно через USB HUB), порты USB 3.0 не поддерживаются. Также не поддерживаются различные сетевые устройства (например, AnywhereUSB) и сетевые перенаправители (например, USBOverNetwork). При невозможности установить ключ защиты в локальный порт компьютера обращайтесь в техподдержку NormaCS.

►В случае, если ключ не будет автоматически распознан системой, запустить Мастер установки оборудования (Пуск ® Панель управления ® Установка оборудования) для того, чтобы операционная система произвела поиск и установку указанного устройства аппаратной защиты.

4.2 Запуск мастера регистрации

Запустите Мастер регистрации. Это может быть сделано на последнем шаге установки системы или позднее – посредством выбора пункта меню Пуск→Все программы→Nanosoft→NormaCS→Мастер регистрации.

Мастер регистрации снабжен контекстно-зависимой справкой, позволяющей получить исчерпывающую информацию по действиям на каждои шаге. Для вызова справки нажмите кнопку “Помощь” (“Help”) на панели мастера или клавишу F1 на клавиатуре компьютера.

4.3 Запрос и активизация лицензии

4.3.1 Начальный экран

► Выберите пункт Запросить лицензию.

4.3.2 Указание серийного номера

►Содержимое полей Программный продукт и Серийный номер продукта должно соответствовать сведениям о регистрируемой копии NormaCS.

4.3.3 Указание реквизитов компании

►Укажите реквизиты вашей компании.

4.3.4 Указание сведений о пользователе

► Укажите регистрационные данные пользователя.

4.3.5 Подтверждение регистрационных данных

►Подтвердите правильность указанной информации.

Для конфигурации с ключом защиты вместо строк, содержащих информацию об аппаратной конфигурации компьютера (ID1:… и ID2:…) в регистрационных данных автоматически указывается серийный номер ключа (HWLock:…).

4.3.6 Запрос лицензии on-line и автоматическая активизация лицензии

Данный вариант является предпочтительным, поскольку в этом случае будет произведен не только запрос файла лицензии, но и его автоматическое получение и активизация.

►Выберите пункт «Запросить лицензию on-line» и нажмите кнопку Далее (Next). При этом будет осуществлена попытка отправки запроса.

В данном окне отображается информация о состоянии процесса передачи данных on-line и выдаче локальной лицензии, о его результате и о причинах в случае неудачи.

►В случае успешного завершения операции нажмите кнопку Далее (Next).

Процесс получения и активизации лицензии успешно завершен. Никаких других действий по лицензированию установленного продукта производить не требуется.

Файл лицензий, полученный таким способом, помещается в папку %ProgramData%\Nanosoft\RegWizard\Licenses.

Рекомендуется сделать резервную копию файла лицензии и сохранить ее в безопасном месте.

►Нажмите кнопку Далее (Next), для запуска Мастера обслуживания NormaCS.

►В случае отказа в выдаче локальной лицензии сервером по той или иной причине, нажмите кнопку Далее (Next), и в последующем окне, содержащем контактную информацию, нажмите кнопку Готово (Finish), завершив работу.

►В случае неудачного соединения с сервером, а так же в случае отсутствия возможности выдачи лицензии выбранным способом, нажмите кнопку Далее (Next) и, вернувшись обратно в окно Способ запроса лицензии, выберите другой вариант осуществления запроса.

Так же имеется возможность послать автоматически созданное электронное письмо в службу поддержки Нанософт с полным протоколом работы Мастера Регистрации. Для этого установите флажок Послать e-mail в Службу Поддержки перед тем как нажать кнопку Далее (Next). Данный вариант имеет смысл в том случае, если Вы уверены, что причиной неудачи on-line лицензирования может являться неправильная работа программного обеспечения Нанософт либо ошибка обработки запроса и выдачи лицензии.

4.3.7 Запрос лицензии по электронной почте

Данный вариант является менее предпочтительным, чем запрос лицензии on-line, поскольку в этом случае запрашиваемый файл локальной лицензии будет выслан по электронной почте, и для активизации лицензии будет необходимо выполнить дополнительные действия.

► Выберите пункт «Запросить лицензию по электронной почте» и нажмите кнопку Далее (Next). При этом будет автоматически создано электронное письмо с запросом в Службу Лицензирования.

Не изменяйте ни тему (subject), ни текст письма: любые изменения могут привести к ошибке при выдаче и при работе лицензии.

►Нажмите кнопку Отправить (Send) в окне почтового клиента. Письмо будет автоматически отправлено по адресу getlicense_normacs@nanocad.ru.

►В появившемся окне, содержащем контактную информацию, нажмите кнопку Готово (Finish).

►При получении электронного письма, содержащего вложенные файл лицензии и файл разделов, cохраните эти файлы на жестком диске и повторно запустите Мастер Регистрации; в стартовом окне выберите пункт Активизировать лицензию и нажмите кнопку Далее (Next).

►Укажите местоположение присланного файла лицензии; нажмите кнопку Далее для регистрации указанного файла лицензии.

►Нажмите Готово для завершения мастера регистрации.

►Вызовите Мастер обслуживания NormaCS.

4.3.8 Запрос лицензии по факсу

Запрос файла локальной лицензии может быть также осуществлен по факсу.

Для этого:

►Выберите пункт Распечатать лицензионный запрос и нажмите клавишу Далее (Next).

►В появившемся диалоге печати установите требуемые параметры и распечатайте регистрационные данные.

►В окне, содержащем контактную информацию, нажмите кнопку Готово (Finish).

►Передайте запрос в компанию Нанософт по номеру факса, указанному на распечатанной странице, с пометкой "Получение лицензии для программы <укажите название программы>".

►При получении электронного письма содержащего файл локальной лицензии, или информации на факс, повторно запустите Мастер Регистрации, в стартовом окне выберите пункт Активизировать лицензию и нажмите кнопку Далее (Next).

Текст файла лицензии, полученных по факсу, следует набрать в текстовом редакторе Блокнот и сохранить на компьютере с расширением .lic.

►Вызовите Мастер обслуживания NormaCS.

4.3.9 Отправка запроса с другого компьютера

Если сетевые службы на компьютере не доступны, имеется возможность сохранить лицензионный запрос в файл и передать его с другого компьютера.

Для этого:

►Выберите пункт Сохранить лицензионный запрос и нажмите кнопку Далее (Next).

►В появившемся диалоге выберите в качестве формата файла в котором будет записан запрос – почтовый формат EML, имя файла и место сохранения.

►В окне, содержащем контактную информацию, нажмите кнопку Готово (Finish).

►Перенесите файл на компьютер, с которого может быть отправлен запрос.

►Откройте файл почтовым клиентом и нажмите в нем кнопку Переслать (Forward). Проверьте, что в поле Адрес отправителя (From) указан Ваш адрес, в поле Получатель (To) введите getlicense_normacs@nanocad.ru и отправьте электронное письмо. Обязательно сохраните тему (subject) и содержание исходного письма без изменений, в противном случае это может привести к ошибке при выдаче и при работе лицензии.

При получении электронного письма содержащего файл локальной лицензии, повторно запустите Мастер Регистрации, в стартовом окне выберите пункт Активизировать лицензию и нажмите кнопку Далее (Next).

►Вызовите Мастер обслуживания NormaCS.

4.3.10 Отказ в регистрации

Если ваш запрос на регистрацию по каким-либо причинам не может быть обработан, ответное письмо будет содержать объяснение причины отказа в регистрации. Возможные основания отказа в регистрации перечислены в разделе Ошибки при запросе лицензии.

5 Мастер обслуживания NormaCS

5.1 Введение

Мастер обслуживания NormaCS (далее мастер обслуживания) предназначен для установки и настройки основного и пользовательских архивов документов NormaCS.

Для вызова мастера обслуживания из меню установленной версии NormaCS, активируйте пункт меню Пуск→Все программы→Nanosoft→NormaCS→Мастер обслуживания

5.2 Начальная установка архива документов

Пожалуйста, примите во внимание, что до начала установки документов следует установить и авторизовать NormaCS.

Установка архива документов может быть произведена только c компьютера, где установлена NormaCS.

►Вызовите мастер обслуживания и выберите режим «Активация». (При запуске из мастера регистрации переход в этот режим выполняется автоматически.)

►Для продолжения требуется файл с информацией о приобретенных разделах (файл разделов).

Нажмите Скачать для получения актуального файла разделов при помощи online-сервиса NormaCS

(файл будет сохранен в папке %ProgramData%\Nanosoft\RegWizard\Licenses),

или нажмите Выбрать для указания ранее сохраненного на диске файла разделов.

Вы также можете получить файл разделов, открыв в браузере страницу по адресу http://www.normacs.ru/mathupdate.jsp

►Подтвердите ваше согласие с условиями использования программы.

►После подтверждения сделанных настроек мастер выполняет активацию присоединеннных баз данных указанным файлом разделов.

►Щелкните на ссылке загрузить документы или нажмите кнопку Загрузить для перехода к загрузке документов архива.

.

►Укажите папки, в которые будут установлены файлы документов.

►Укажите путь на первый диск дистрибутива установки или на корневую папку развернутого архива NormaCS.

►Мастер выполняет установку документов.

.

5.3 Ошибки при установке документов

5.3.1 Ошибки авторизации

Установка архива документов возможна только при наличии на используемом компьютере авторизованной версии NormaCS. В противном случае при запуске установки выдается сообщение об ошибке авторизации с описанием ошибки и рекомендацией по ее устранению. Список ошибок авторизации приведен в разделе Ошибки при проверке лицензии.

Пример окна с сообщением об ошибке авторизации.

5.3.2 Ошибки разбора файла разделов

Указанные ошибки возникают в том случае, когда файл разделов поврежден или не соответствует лицензии. Если вам не удается исправить ошибку своими силами, сообщите в службу поддержки, приложив к письму используемые файл лицензии и файл разделов.

6 Обновление NormaCS

Для установки обновления NormaCS пользователь должен иметь права администратора.

6.1 Содержимое установочных дисков

Первый диск содержит следующие папки и файлы.

  • Корневая папка

o    Метка диска

o    Описание поставки

o    Контрольные суммы файлов на диске

o    Шаблон для указания информации о дилере

o    Контрольный файл обновления

o    Файлы меню автозапуска

  • Папка addonBase – архивы документов для дополнительных баз данных
  • Папка addons – надстройки для работы с дополнительными форматами документов
  • Папка bin – меню автозапуска
  • Папка documentation

o    Руководство по установке и авторизации (этот документ)

o    Руководство администратора NormaCS Server

o    Руководство пользователя

o    Лицензионное соглашение

  • Папка npu – обновления для основной и/или дополнительных баз данных
  • Папка documents – документы NormaCS
  • Папка sentinel_drivers – драйверы аппаратной защиты
  • Папка setup_update – установка обновления NormaCS

Остальные диски:

  • Корневая папка

o    Метка диска

o    Описание поставки

o    Контрольные суммы файлов на диске

  • Папка documents – документы NormaCS.

6.2 Начало установки

►Вставьте в дисковод первый установочный диск.

►Если авто-запуск с компакт-дисков отключен, то вызовите файл setup_update.exe из корневой папки первого установочного диска.

►В окне приветствия нажмите кнопку Далее.

6.3 Перед выполнением

►Просмотрите текущие установки перед началом копирования файлов.

Нажмите кнопку Далее для начала копирования.

6.4 Выполнение

► Дождитесь завершения процесса копирования файлов с первого диска.

Если дистрибутив содержит несколько дисков, программа поочередно их запрашивает.

6.5 Завершение установки

►Нажмите Готово, чтобы завершить программу установки.

6.6 Ошибки при установке обновления

Установка обновления возможна только при наличии на используемом компьютере авторизованной версии NormaCS. В противном случае при запуске установки выдается сообщение об ошибке авторизации с описанием ошибки и рекомендацией по ее устранению. Список ошибок авторизации приведен в разделе Ошибки при проверке лицензии.

7 Установка и обновление сетевого клиента NormaCS

Сетевой клиент для многопользовательской версии NormaCS устанавливается после установки, авторизации и запуска сервера NormaCS.

7.1 Полная установка/обновление

Полная установка или обновления сетевого клиента выполняется администратором посредством загрузки с сервера и последующего запуска дистрибутива установки.

Для выполнения полной установки или обновления сетевого клиента NormaCS пользователь должен иметь права администратора.

Более подробно порядок полной установки или обновления описан в Руководстве администратора NormaCS Server.

7.2 Динамическое обновление

Динамическое обновление сетевого клиента выполняется автоматически при запуске на рабочей станции клиента NormaCS. В ходе обновления с сервера на рабочую станцию передается и распаковывается в папку клиента пакет с новыми файлами.

Для выполнения динамического обновления требуются права на изменение и запись в папке программных файлов клиента. Начальная установка клиента позволяет создать учетную запись с указанными правами, от имени которой будет производиться обновление, что позволяет разрешить ситуацию, когда текущий пользователь не обладает достаточными правами.

8 Мастер интеграции NormaCS

Мастер интеграции NormaCS позволяет добавить к другим приложениям возможность вызова NormaCS . Интегрируемое приложение получает дополнительные пункт меню и панель инструментов с кнопкой запуска NormaCS .

Существующая версия мастера позволяет произвести автоматическую интеграцию с приложениями Microsoft Office и Autodesk AutoCAD. Для запуска NormaCS из других приложений используйте команду explorer normacs:show.

8.1 Начало установки

Запустите Мастер интеграции NormaCS. Для NormaCS Desktop это может быть сделано на последнем шаге установки системы или позднее – посредством выбора пункта меню NormaCS ® Мастер интеграции. Функции мастера интеграции доступны также из меню Правка ® Настройки приложения NormaCS.

8.2 Выбор продуктов для интеграции

►В диалоге Мастера интеграции установите или снимите отметку интеграции для желаемых продуктов.

Нажмите кнопку ОК для продолжения.

8.3 Просмотр настроек перед началом интеграции

►Подтвердите правильность сделанных установок.

Нажмите кнопку ОК для запуска процедуры интеграции.

8.4 Завершение установки

►Нажмите кнопку ОК для завершения интеграции.

9 Устранение ошибок

9.1 Обращение в службу поддержки

Адрес электронной почты службы поддержки NormaCS – normacs@normacs.ru.

При обращении в службу поддержки NormaCS просим вас предоставить следующую информацию:

► Характеристики поставки и окружения:

  • Версия NormaCS – сетевая/локальная, количество клиентов
  • Тип лицензирования – на аппаратный ключ или нет
  • Лицензионный номер
  • Файл лицензии, полученный вами по почте
  • Версия поставки из файла Disk1.id на первом инсталляционном диске
  • Если были установлены обновления, то версию последнего обновления из файла Disk1.id на диске с обновлением
  • Версия операционной системы и Internet Explorer на сервере и клиентских машинах
  • Характеристики процессора, оперативной памяти и дисковых накопителей на сервере и клиентских машинах
  • Производителя, модель и версию драйверов сетевого адаптера на сервере и клиентских машинах
  • Путь, по которому установлено приложение NormaCS
  • Файл normacs.ini или normacssrv.ini из папки программных файлов NormaCS
  • Файл history из папки idx, вложенной в папку программных файлов NormaCS
  • Файлы с расширением ‘.LOG’ из папки программных файлов NormaCS и вложенной в нее папки log

► Описание проблемы:

  • Детальное описание проблемы
  • Действия, приведшие к проблеме
  • Снимки экранов сообщений об ошибках
  • Для сетевой версии – снимок экрана страницы состояния сервера

Вы можете подготовить и отослать данные для техподдержки, вызвав
Пуск ® Все Программы ® Nanosoft ® NormaCS ® Собрать данные для службы техподдержки

9.2 Ошибки программы установки

Ситуация

Рекомендуемые действия

После запуска установки появляется сообщение об ошибке копирования файла IKernel.exe (см. снимок экрана ниже)

1. Проверьте, не была ли программа установки (процесс с именем IKrernel.exe), запущена ранее и до сих пор не завершена. Если это имело место, завершите указанный процесс и повторите установку.

2. Убедитесь в наличии прав копирования в папку, указанную в сообщении об ошибке.

Проблема: в произвольный момент установки возникает сообщение

error in the file .dll: setup.Log_Info

0x80040707

После чего окно установщика закрывается, но процесс IKernel.exe продолжает выполняться.

Ошибка возникает в случае отсутствия или неправильного значения некоторых ключей реестра компьютера. Для исправления выполните следующие действия (более подробное описание см.

http://consumer.installshield.com/kb.asp?id=Q108167 ).

· Выберите Пуск->Выполнить (Start > Run) .

· Напечатайте Regedt32.exe . Щелкните OK .

· Найдите ключ HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Current Version\Explorer\User Shell Folders.

· Проверьте, что в этом ключе находятся (по крайней мере) следующие значения.

Наименование | Данные
Common Desktop | %ALLUSERSPROFILE%\Desktop
Common Programs | %ALLUSERSPROFILE%\Start Menu\Programs
Common Startup | %ALLUSERSPROFILE%\Start Menu\Programs\Startup
Common Start Menu | %ALLUSERSPROFILE%\Start Menu

Если хотя бы один из этих ключей указывает на неверное место, установка не сможет выполниться.

· Если ключи отсутствуют, то их надо создать:

1. Нажмите на свободном месте правую клавишу мыши и выберите
Новое->Строковое значение (New > Expandable String Value .)

2. Наберите имя ключа, например, Common Programs.

3. Правой кнопкой щелкните на созданный ключ и выберите Изменить (Modify) .

4. Введите правильное значение (из таблицы выше)

5. Проверьте, что такая папка существует. Если нет создайте ее.

%ALLUSERSPROFILE% - обычно это c:\documents and settings\All Users

6. Перезагрузите компьютер.

9.3 Ошибки при запросе лицензии

Текст в письме от робота

Рекомендуемые действия

Лимит лицензий по данному серийному номеру на запрошенный Вами продукт исчерпан.

Невозможно создать лицензию по Вашему запросу.

Лицензия по вашему серийному номеру уже была выдана на другой компьютер.

Для установки NormaCS на несколько рабочих станций, приобретите сетевую версию, или защиту на аппаратном ключе.

Обратитесь к вашему дилеру для разрешения проблемы.

Информация о купленных Вами разделах находиться в обработке.

Попробуйте повторно запросить лицензию через 24 часа. Если она не будет готова, обратитесь к Вашему дилеру.

Невозможно создать лицензию по Вашему запросу.

Информация о купленных Вами разделах находиться в обработке. Без нее не возможно использовать продукт.

Попробуйте повторно запросить лицензию через 24 часа. Если она не будет готова, обратитесь к Вашему дилеру.

Неверный серийный номер.

Невозможно создать лицензию по Вашему запросу.

В запросе был указан неверный серийный номер, если вы набирали письмо вручную, то проверьте правильность ввода.

9.4 Ошибки при проверке лицензии

Код ошибки | Описание | Рекомендуемые действия
1, 5, 18 | Не найден файл лицензии. | Установите лицензию согласно пункту Авторизация NormaCS настоящего руководства.
2, 8, 11, 30 | Файл лицензии поврежден. | Восстановите лицензию из резервной копии или запросите ее повторно.
9 | Конфигурация вашего компьютера не совпадает с конфигурацией, указанной в файле лицензии. | Если вы используете устройство аппаратной защиты (USB-ключ), то удостоверьтесь, что он вставлен, и что драйверы аппаратной защиты установлены. Если вы авторизовали программу на локальный компьютер, то убедитесь, что установка документов запущена с того же компьютера.
10 | Истек срок пользования программным продуктом. | Обратитесь к вашему дилеру за продлением лицензии.
31 | Не наступил срок начала использования программы. | Проверьте установленное на компьютере время.
88 | Часы компьютера были переведены назад
103 | Использование программы из-под сессии терминального сервера запрещен | Запускайте программу из-за консоли компьютера
другой код | Внутренняя ошибка | Обратитесь в службу поддержки.

9.5 Ошибки разбора файла разделов

Указанные ошибки возникают при установке архива документов в том случае, когда используемый файл разделов поврежден или не соответствует лицензии. Если вам не удается исправить ошибку своими силами, сообщите в службу поддержки, приложив к письму используемые файл лицензии и файл разделов.

9.6 Ошибки при запуске службы сервера

Ошибки запуска сервера можно увидеть в Журнале событий (Пуск > Панель управления > Администрирование > Просмотр события).

Код ошибки | Описание | Рекомендуемые действия
1 | Ошибка проверки лицензии | Смотрите код в описании события и действуйте согласно пункту Ошибки при проверке лицензии.
2 | Порт занят | TCP-порт, выбранный для NormaCS Server занят другим приложением. Укажите другой порт или закройте то приложение
4 (Предупреждение) | Превышено максимальное число пользователей | При частом повторении данного предупреждения рекомендуем докупить клиентских лицензий, т.к. ваши пользователи часто не могут попасть в программу
8 | Поврежден файл разделов | Проверьте файл разделов при помощи Мастера установки документов и следуйте рекомендациям пункта Ошибки разбора файла разделов.
9 | Служба сервера не имеет доступа к папкам документов или файлу базы данных | Проверьте права доступа и назначьте их согласно руководству администратора.
10 | Найдено несколько лицензионных файлов | Запустите Мастер установки документов для локализации и устранения устаревших файлов.
11 | Неудача старта подсистемы NTLM | Если указанный для NTLM порт занят, то его необходимо изменить в ini файле. Если не создан файл normacssrv.sec, то его нужно создать утилитой NormaCSSecurityManager.
12 | База данных повреждена или установка NormaCS не была закончена | Установите обновление NormaCS.

Возможные проблемные ситуации при запуске службы сервера и пути их устранения описаны в подразделе Проблемы при запуске службы раздела Служба сервера Руководства администратора NormaCS Server.

9.7 Ошибки при запуске клиента

Ситуация

Сообщение об ошибке

Возможная причина и рекомендуемые действия

При запуске клиента возникает ошибка

Ошибка связи с NormaCS сервером.

Указанный порт не отвечает

(Код ошибки: 12029)

· Не запущен сервер – проверьте, запущена ли служба NormaCS Server на компьютере сервера.

· Нарушена связь с компьютером сервера – проверьте правильность соединения с компьютером сервера.

· В настройке клиента указан порт связи, отличный от TCP-порта сервера – проверьте соответствие номера порта в параметре netConnection профайла клиента и listenport в профайле сервера.

· В настройке клиента указано имя компьютера, отличное от имени компьютера сервера – проверьте соответствие имени компьютера в параметре netConnection профайла клиента и listenport в профайле сервера.

При запуске клиента возникает ошибка

Ошибка связи с NormaCS сервером.

Имя не найдено

(Код ошибки: 12007)

Не удается разрешить имя сервера или адрес.

· Проверьте правильность указания имени сервера в настройках клиента.

· Возможна ошибка в конфигурации используемых служб DNS, WINS или DHCP на клиенте или на сервере. Проверьте свойства TCP/IP для данных служб.

При запуске клиента возникает ошибка

Неверно указан адрес сервера в настройках

Не указан или неправильно указан адрес сервера в настройках клиента. Проверьте правильность указания имени сервера и номера порта в профайле клиента.

При запуске клиента возникает ошибка

Ошибка связи с NormaCS сервером.

Таймаут

(Код ошибки: 12002)

Удаленный сервер не ответил за отведенное время. Возможно, сервер сейчас недоступен. Попробуйте повторить запуск позже.

При запуске клиента возникает ошибка

У вас нет прав доступа к NormaCS серверу

Сервер отказал в доступе клиенту, запущенному с данного компьютера.

· IP-адрес компьютера не указан в списке алресов компьютеров, с которых разрешен доступ к серверу

· Пользователь не указан в списке NTLM-доступа (если включена NTLM-аутентификация).

Запустите менеджер бнзопасности (NormaCS Security Manager) для просмотра или редактирования настроек доступа к серверу.

При запуске клиента возникает ошибка

Превышено максимально допустимое число соединений с NormaCS сервером. Попробуйте позже.

В настоящий момент сервер обслуживает максимально доступное количество клиентов, так что подключение возможно только после завершения работы одним из клиентов.

9.8 Ошибки при открытии документов

Ситуация | Сообщение об ошибке | Возможная причина и рекомендуемые действия
При открытии текста документа возникает ошибка | Data accessor exception: type:6 code:6001 msg:CDocFile:cannotopen the file 'csnet://pph/60/6060.pph' file:csnet://pph/60/6060.pph | Файл с документом поврежден или отсутствует на диске. Обратитесь к администратору для проверки и восстановления архива документов с помощью мастера установки документов.
При открытии текста документа возникает ошибка | Data accessor exception: type:7 code:-2146893799 msg:Error during Crypt Acquire Context errorcode-2146893799 | Не установлены пакеты обновлений для Windows 2000. Минимально требуется SP2.
При открытии карточки документа возникает ошибка | Ошибка отображения XML документа Неизвестный протокол: csnet://static/document_card2.xsl. | При установке не был зарегистрирован компонент NormaCS. Переустановите клиента или запустите утилиту регистрации NormaCS regncs.exe из папки программных файлов клиента.

© ЗАО «Нанософт», 2016
Все права защищены.